Forum Outage, Part Deux

And now, a word from our moderators

Moderators: Yash, Tom

Message
Author
User avatar
Not-so-Veteran
Posts: 1238
Joined: Fri Jul 29, 2016 2:15 pm
Location: The world between the molecules.

Re: Forum Outage, Part Deux

#16 Post by ThunderVolt » Thu Apr 06, 2017 1:21 am

Ah, I see. Otherwise, I'm not too bothered by the new look. Quotes do look weird, though. Got any intentions to reversing it back to the way it was or must I get used to this?

And I'm not too familiar with what subsilver and prosilver is. Whatever.

Good to know you disabled the video boxes. So I don't link something, have it not working and look like an idiot.

I do like how the forum automatically makes your avatar smaller to see next to your user drop-down, if it's big.

Nice work!

User avatar
Site Admin
Posts: 112
Joined: Wed Nov 10, 2010 3:32 am
Location: Michigan, USA
Contact:

Re: Forum Outage, Part Deux

#17 Post by Turaiel » Thu Apr 06, 2017 1:25 am

ThunderVolt wrote:
Thu Apr 06, 2017 1:21 am
Quotes do look weird, though. Got any intentions to reversing it back to the way it was or must I get used to this?
You'll have to get used to it. The old themes are incompatible. Tweaks are possible.
ThunderVolt wrote:
Thu Apr 06, 2017 1:21 am
And I'm not too familiar with what subsilver and prosilver is. Whatever.
Subsilver is the old phpBB theme we used before (with the addition of some modifications). It was the default theme for phpBB for several years. As of phpBB 3.2, it is no longer supported. Prosilver is a newer theme that is now the default for phpBB. It has the advantage of being responsive as well, so the forum properly scales on mobile. You have the option of switching to the plain old Prosilver theme in your user CP. The theme we're using now is a mod on Prosilver that gives it the design of Subsilver, again with some custom additions from me.
Website and Facebook Page Administrator
Links // TK on Facebook // TK extras archive // deviantART

User avatar
Council Member
Posts: 555
Joined: Fri Dec 09, 2016 9:32 pm
Location: France

Re: Forum Outage, Part Deux

#18 Post by Cyon » Thu Apr 06, 2017 5:37 pm

Sidenote: on Tuesday, I changed my password as was recommended, yet when I tried signing on today it had reverted to my previous one. No idea what happened, but though I should point it out as it was working fine two days ago.
Who even looks at signatures anyways?

Multitasking is just a way to be less efficient at two different things simultaneously

Furcode: FCWp5ad A- C->+ D H+ M- P? R++ T++ W? Z- Sm# RL- a- cl++ d+ e- f h* i++ j? p- sm-

User avatar
Master
Posts: 243
Joined: Sun Mar 08, 2015 7:03 pm
Location: 127.0.0.1

Re: Forum Outage, Part Deux

#19 Post by puredeathly » Fri Apr 07, 2017 2:09 pm

Thx for fixing the forum (again)!
Can confirm the part about phpBB being a sieve of exploits and I know how tiring this can be...

User avatar
Grand Templar
Posts: 1291
Joined: Tue Jan 22, 2013 2:47 pm
Location: Mekkan Raceway
Contact:

Re: Forum Outage, Part Deux

#20 Post by jacobc62 » Mon Apr 10, 2017 3:29 am

As a heads up, the profanity filter isn't working properly (for me at least). I have it turned off, but profane language is still hidden behind "[censored]".


I know, probably not gonna be the highest thing on your "to fix" list, just figured I'd bring it to your attention.
Image
Image
"That poor, sexy [censored]...." -Evals Vaughan, October 2016

User avatar
Templar Inner Circle
Posts: 6263
Joined: Sat Apr 09, 2011 6:08 pm
Location: https://goo.gl/7ARWF4

Re: Forum Outage, Part Deux

#21 Post by TinyVoices » Mon Apr 10, 2017 5:17 am

jacobc62 wrote:
Mon Apr 10, 2017 3:29 am
As a heads up, the profanity filter isn't working properly (for me at least). I have it turned off, but profane language is still hidden behind "[censored]".


I know, probably not gonna be the highest thing on your "to fix" list, just figured I'd bring it to your attention.
Are you [censored] seeing this [censored]? : P
I don't think I've noticed that bug, but I may as well check.

(edit- It's broke, boss. Unless it's supposed to do that by default in this particular board now.)


I have my own thinger to mention. I've found if I scroll before the page is fully loaded, scrolling with my mouse wheel will stop working. Anywhere where scrolling should work, won't work, until I fix the issue. I fix the issue by opening a new tab. I can either just open a forum location into a new tab (such as middle clicking the forum logo to go back to the index page) or just open a new Incognito tab and navigating back to the forum.

Pretty sure it's only if I scroll before the page is done loading, but only til now have I even found the bug so I gotta look into it more. Though it is very easy to replicate and fix (and technically avoid, too).


OH. And the forum search seems to be really derpy right now. It doesn't want to search for certain words. For example, it 500 errors after a while of trying to look for veteran, templar, or friend. But it can do things like season, journey, and board just fine. After messing with it some, it seems as though if the word has too common of a result number, it borks. But if you limit your search by board it does a better job in some cases. So it probably can handle the number of results or something. That's my guess anyway...

User avatar
Delta-17
Posts: 1087
Joined: Wed Aug 15, 2012 11:31 pm
Location: Arizona

Re: Forum Outage, Part Deux

#22 Post by Fawkes » Mon Apr 10, 2017 6:57 am

I just want to mention that I have noticed that both the same word censoring bug that is happening to jacobc62 and the scroll wheel bug TinyVoices described are happening to me as well.
"Why worry? If you've done the very best you can, worrying won't make it better." - Walt Disney

"Because when I retire, I want a television the size of a billboard." - Felix (RvB)

"Crikey?" - Rookie Imposter

User avatar
Site Admin
Posts: 112
Joined: Wed Nov 10, 2010 3:32 am
Location: Michigan, USA
Contact:

Re: Forum Outage, Part Deux

#23 Post by Turaiel » Tue Apr 11, 2017 9:15 pm

jacobc62 wrote:
Mon Apr 10, 2017 3:29 am
As a heads up, the profanity filter isn't working properly (for me at least). I have it turned off, but profane language is still hidden behind "[censored]".
Some quick research tells me this is a bug in the current version of phpBB. Hopefully the next version will resolve it.
Website and Facebook Page Administrator
Links // TK on Facebook // TK extras archive // deviantART

User avatar
Site Admin
Posts: 112
Joined: Wed Nov 10, 2010 3:32 am
Location: Michigan, USA
Contact:

Re: Forum Outage, Part Deux

#24 Post by Turaiel » Wed Apr 12, 2017 12:30 am

TinyVoices wrote:
Mon Apr 10, 2017 5:17 am
OH. And the forum search seems to be really derpy right now. It doesn't want to search for certain words. For example, it 500 errors after a while of trying to look for veteran, templar, or friend. But it can do things like season, journey, and board just fine. After messing with it some, it seems as though if the word has too common of a result number, it borks. But if you limit your search by board it does a better job in some cases. So it probably can handle the number of results or something. That's my guess anyway...
I switched the search system the forum was using and rebuild the search index. It should work decently now.
Website and Facebook Page Administrator
Links // TK on Facebook // TK extras archive // deviantART

User avatar
Templar Inner Circle
Posts: 6263
Joined: Sat Apr 09, 2011 6:08 pm
Location: https://goo.gl/7ARWF4

Re: Forum Outage, Part Deux

#25 Post by TinyVoices » Thu Apr 20, 2017 5:32 am

Fawkes wrote:
Mon Apr 10, 2017 6:57 am
I just want to mention that I have noticed that both the same word censoring bug that is happening to jacobc62 and the scroll wheel bug TinyVoices described are happening to me as well.
Regarding the scroll wheel bug, I think I may have figured what the issue is but we'll need to confirm it. :P

Fawkes, do you use Chrome on the forum?

My point being I found a Chrome bug thread that sounds like what is plaguing me. Current version of Chrome (go to chrome://version and look for Google Chrome: 57.0.etc) has a good chance to lock scroll wheels up if you are scrolling while a page is loading. They were able to isolate the issue and according to that thread will have it fixed in the next update (version 58) coming up here soon.


This doesn't outright affect this site, only people who use Chrome version 57 to view this site. (And technically if you use Chrome on a lot of other sites, too.)

I did what the following suggested to do, and it works so far to fix the issue. But otherwise it seems holding out for another week for the next update might fix it anyway. :P
Hi there. The fix missed version 57 on most (all?) platforms. But the good news is that it should ship in version 58, which according to https://www.chromium.org/developers/calendar should *about* next week. You can check what version you're in in chrome://version.

In the mean time, you can fix the issue by disabling chrome://flags/#smooth-scrolling
Obviously since in a week this will all be irrelevant, I just wanted to state it in case someone was trying to figure out what was wrong with the Forums regarding the bug.

User avatar
No hugs, I asplode.
Posts: 3848
Joined: Wed May 06, 2009 5:37 am
Location: Somewhere, I'm sure.
Contact:

Re: Forum Outage, Part Deux

#26 Post by Lief » Thu Apr 20, 2017 1:36 pm

If you're still poking around with the themes at all, Turaiel, I have a request.

Would it be possible to get a darker theme in the same style as the current default? (Twokinds Subsilver) It's something that's been bothering me since before the outage but I hadn't gotten around to mentioning anything. I like the colors (Or is it shades?) of the current theme fine, but it kills my eyes at night, which is when I'm most active on here.
Image
Image
Don't ask, its better that way.

User avatar
Site Admin
Posts: 112
Joined: Wed Nov 10, 2010 3:32 am
Location: Michigan, USA
Contact:

Re: Forum Outage, Part Deux

#27 Post by Turaiel » Thu Apr 20, 2017 1:53 pm

Lief wrote:
Thu Apr 20, 2017 1:36 pm
If you're still poking around with the themes at all, Turaiel, I have a request.

Would it be possible to get a darker theme in the same style as the current default? (Twokinds Subsilver) It's something that's been bothering me since before the outage but I hadn't gotten around to mentioning anything. I like the colors (Or is it shades?) of the current theme fine, but it kills my eyes at night, which is when I'm most active on here.
No, sorry. It'll be difficult enough to maintain one extra theme as the forum gets upgraded. There are browser extensions that can automatically switch websites to dark themes (such as Dark Reader for Chrome). You can also use a blue light filter at night (such as F.lux or macOS' and iOS' Night Shift feature) to make things easier on your eyes.
Website and Facebook Page Administrator
Links // TK on Facebook // TK extras archive // deviantART

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest