[COMPLETED] Forum Upgrade 2020-11-06

Announcements about forum and website maintenance

Moderator: Moderators

Post Reply
Message
Author
User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

[COMPLETED] Forum Upgrade 2020-11-06

#1 Post by Turaiel »

The forum was upgraded to a new version of phpBB on Friday, 6 November 2020. Maintenance was completed at 6 Nov 21:37 UTC (4:37 PM EST). This was a minor maintenance upgrade.

If you encounter any issues, please reply to this thread.

Thanks for your patience!
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
Hayate
The Hidden User
Posts: 1415
Joined: Mon Feb 22, 2016 4:06 am

Re: [COMPLETED] Forum Upgrade 2020-11-06

#2 Post by Hayate »

Well it seems to have fixed an issue I was having with drop menus not working on mobile. I thought it was just my phone.
~Hayate~
--Moderator/Global Moderator
--

--Forum Rules--
--Moderators --
--Administrators
--

User avatar
Technic[Bot]
Templar GrandMaster
Posts: 922
Joined: Sat Jan 27, 2018 9:48 pm
Location: México
Favorite Character: Keith!
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#3 Post by Technic[Bot] »

This also fixed the an issue where images did not rendered on my weird mobile browser. (Firefox focus). Nice!
There are three things that motivate people: Money, fear and love.
Links to my ramblings:
Twokinds [of] data
PhpBB in the age of facebook
If you are new to this phpBB thing:
BBCode guide

User avatar
MuonNeutrino
Templar GrandMaster
Posts: 645
Joined: Sun Mar 17, 2013 8:55 pm
Location: Sol system, Orion spiral arm, Milky Way
Favorite Character: Rose, Natani

Re: [COMPLETED] Forum Upgrade 2020-11-06

#4 Post by MuonNeutrino »

Possible bug: all threads that try to post comic images by referring to direct links to image files at cdn.twokinds.keenspot.com (e.g. http://cdn.twokinds.keenspot.com/comics/20201010.png for the thread for october 10th ) are returning as broken images, even though the image files themselves are valid. I'm not sure if this is on the forum's side or on the main twokinds site's side, but definitely not the correct behavior.
Image

User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#5 Post by Turaiel »

MuonNeutrino wrote: Sun Nov 08, 2020 11:50 pm Possible bug: all threads that try to post comic images by referring to direct links to image files at cdn.twokinds.keenspot.com (e.g. http://cdn.twokinds.keenspot.com/comics/20201010.png for the thread for october 10th ) are returning as broken images, even though the image files themselves are valid. I'm not sure if this is on the forum's side or on the main twokinds site's side, but definitely not the correct behavior.
Working fine for me, might be something on your end?
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
Technic[Bot]
Templar GrandMaster
Posts: 922
Joined: Sat Jan 27, 2018 9:48 pm
Location: México
Favorite Character: Keith!
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#6 Post by Technic[Bot] »

The Thread mount linked has the same issue for me, image doesn't show.
There are three things that motivate people: Money, fear and love.
Links to my ramblings:
Twokinds [of] data
PhpBB in the age of facebook
If you are new to this phpBB thing:
BBCode guide

User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#7 Post by Turaiel »

What browser?
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
MuonNeutrino
Templar GrandMaster
Posts: 645
Joined: Sun Mar 17, 2013 8:55 pm
Location: Sol system, Orion spiral arm, Milky Way
Favorite Character: Rose, Natani

Re: [COMPLETED] Forum Upgrade 2020-11-06

#8 Post by MuonNeutrino »

I am using Chrome under windows 7, if it matters. I have a scriptblocker (umatrix), but it's not set to block anything on this site.
Image

User avatar
MuonNeutrino
Templar GrandMaster
Posts: 645
Joined: Sun Mar 17, 2013 8:55 pm
Location: Sol system, Orion spiral arm, Milky Way
Favorite Character: Rose, Natani

Re: [COMPLETED] Forum Upgrade 2020-11-06

#9 Post by MuonNeutrino »

Also for some reason I can't edit my previous post, but the october 10th thread I linked looks like this to me: https://i.imgur.com/iPFpKiQ.png
Image

User avatar
Technic[Bot]
Templar GrandMaster
Posts: 922
Joined: Sat Jan 27, 2018 9:48 pm
Location: México
Favorite Character: Keith!
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#10 Post by Technic[Bot] »

In my case was a firefox on ubuntu running as locker and also blocking javascript.
Yes my setup is rather weird but, that is why never said anything before. In any case other threads and images work fine. Also tried linking the diorama raw image a couple weeks ago and that fails to load too.
There are three things that motivate people: Money, fear and love.
Links to my ramblings:
Twokinds [of] data
PhpBB in the age of facebook
If you are new to this phpBB thing:
BBCode guide

User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#11 Post by Turaiel »

It looks like Chrome is forcing HTTPS when loading the content and as a result is failing since we don't support HTTPS. I'll look into getting that fixed.
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#12 Post by Turaiel »

Still working on the HTTPS fix. In the meantime we have also fixed an issue preventing registration due to reCAPTCHA changes that were not announced.
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
Technic[Bot]
Templar GrandMaster
Posts: 922
Joined: Sat Jan 27, 2018 9:48 pm
Location: México
Favorite Character: Keith!
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#13 Post by Technic[Bot] »

Does that has anything to do with the recent dns over https change they rolled out a couple months ago?
Where by default the browser will try using https to connect to dns?
There are three things that motivate people: Money, fear and love.
Links to my ramblings:
Twokinds [of] data
PhpBB in the age of facebook
If you are new to this phpBB thing:
BBCode guide

User avatar
Turaiel
Administrator
Posts: 284
Joined: Wed Nov 10, 2010 3:32 am
Location: Ann Arbor, MI, USA
Favorite Character: Natani
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#14 Post by Turaiel »

No, unrelated. Chrome is detecting that an HTTPS site exists for twokinds.keenspot.com and is replacing the HTTP url with HTTPS when it loads it. This is behavior I was previously unaware of. Usually HTTP content is just blocked on HTTPS sites. Unfortunately the HTTPS version of Twokinds doesn't actually serve up anything, hence the blank image.
Website Administrator
Links // TK on Facebook // TK extras archive

User avatar
Technic[Bot]
Templar GrandMaster
Posts: 922
Joined: Sat Jan 27, 2018 9:48 pm
Location: México
Favorite Character: Keith!
Contact:

Re: [COMPLETED] Forum Upgrade 2020-11-06

#15 Post by Technic[Bot] »

Well if it helps the issue is also present in my firefox browser (Mozilla Firefox 82.0.3) and Chrome (Google Chrome 86.0.4240.198) curiously enough Chromium (Chromium 86.0.4240.75 Built on Ubuntu , running on Ubuntu 18.04
) renders both the page than Muon linked and the diorama fine.
There are three things that motivate people: Money, fear and love.
Links to my ramblings:
Twokinds [of] data
PhpBB in the age of facebook
If you are new to this phpBB thing:
BBCode guide

Post Reply